Jira Service Desk compatibility

Server only

This guide applies to server customers on older versions of Service Desk only.

If you are running on an older version of Jira and Jira Service Desk (older than Jira 7.3 or Service Desk 3.3) then a number of Service Desk related features will not be available or limited.

Removed functionality

If you are running an older version of Jira Service desk, these features will not be available:

  • Triggers
    • SLA threshold breached
  • Actions
    • Add Service Desk customer
    • Create Service Desk request

Limited functionality

  • User Conditions will not allow checks to see if a user is in an organization or a customer
  • Service Desk fields like 'Request participant', 'Organization', 'Request type' will not be available in actions that support editing fields such as Create, Edit and Clone issue
  • Sending e-mails to Service desk specific recipients such as 'Pending approvers' will not be possible

Supported versions

To get access to the features above, you need to upgrade to:

  • Jira Core 7.3 or later
  • Jira Service Desk 3.3 or later